A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2026 - 14:28 CEST
Identified
Our infrastructure provider is experiencing intermittent DNS lookup failures. This leads to intermittent connection problems of our servers. We are working to resolve this with high intensity with our infrastructure provider.
Posted Jul 01, 2026 - 13:58 CEST
Investigating
There is an issue with one of our infrastructure providers that is causing degraded performance of all Eturnity products.
Posted Jul 01, 2026 - 10:47 CEST
This incident affected: Eturnity Expert, Eturnity Solar Calculators, Eturnity Heating Calculators, and Eturnity Configurator.